Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase, mail # dev - Re: hbase 0.94.0 failed to individually run test case with org.apache.hadoop.hbase.TestZookeeper


Copy link to this message
-
Re: hbase 0.94.0 failed to individually run test case with org.apache.hadoop.hbase.TestZookeeper
Ted Yu 2012-10-30, 03:37
Can you try with 0.94.2 or tip of 0.94 ?
0.94.0 is quite old.

On Mon, Oct 29, 2012 at 8:31 PM, Liping Zhang <[EMAIL PROTECTED]> wrote:

> Hi  hbase deve, QA, Shixing,
>
> I'll highly appreciate you if you can answer the questions.
>
>
> Hi Shixing,
>
> I found in HBASE-6269, you did a full unit tests, but did you try it
> successfully with individually running "mvn -Dtest=*TestHRegion *test"?
> Thanks for your info.
>
>
>
> ---------- Forwarded message ----------
> From: Liping Zhang <[EMAIL PROTECTED]>
> Date: Tue, Oct 30, 2012 at 11:18 AM
> Subject: hbase 0.94.0 failed to individually run test case with
> org.apache.hadoop.hbase.TestZookeeper
> To: [EMAIL PROTECTED], [EMAIL PROTECTED], [EMAIL PROTECTED]
>
>
>
> Hi Ted Yu, Stack and Andrew,
>
> How are thing going?  I met some issues when I individually run HBase
> 0.94.0 unit tests, can you help me out?
>
> -------------------------
> *question #1:*
>
> I downloaded with Hbase 0.94.0 and run it with unit tests, found that it
> was failed to *individually *run org.apache.hadoop.hbase.TestZookeeper
> and org.apache.hadoop.hbase.regionserver.TestHRegion when I individually
> ran it with "mvn -Dtest=TestZookeeper test" and "mvn -Dtest=TestHRegion
> test". It seems there was no unit testThe result showed as following:
>
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
>
> Results :
>
> *Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
>
>
> --------------------------
> question #2:*
>
> How to skip to some test cases when I run full Hbase unit tests? Is there
> any command?
>
>
> ----------------------------
> *question #3:*
> I tried individual tests, and found that it didn't run any test case with
> "mvn -Dtest=*TestHRegion *test", but it  can run test cases with "mvn
> -Dtest=*TestKeyValue,TestHRegion* test",  do you know why it happens?*
> *
> Thanks very much for your answering!
>
> --
> Thanks!
>
> Best Regards,
> Liping Zhang
>
>
>
>
> --
> Thanks!
>
> Best Regards,
> Liping Zhang(张 莉苹)
>
>
+
Liping Zhang 2012-10-30, 03:58
+
Ted Yu 2012-10-30, 03:43
+
Ted Yu 2012-10-30, 04:50
+
Nicolas Liochon 2012-10-30, 09:27
+
Liping Zhang 2012-11-01, 16:43
+
Liping Zhang 2012-10-30, 04:07