Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # dev >> Re: [VOTE] JDK 1.7 - Switch for Accumulo 1.6.0


Copy link to this message
-
Re: [VOTE] JDK 1.7 - Switch for Accumulo 1.6.0
Adam, the question isn't whether we should stop supporting users on
Java 1.6. The question is whether they'd be enticed by 1.6.0 features
enough to be willing to install its prerequisites. Accumulo 1.5.0 will
continue to run on 1.6 JVMs without issue, and we can continue to
support that so long as there are a significant user group unwilling
to say goodbye to Java 1.6.

As for the motivating feature. There are some nice features
(try-with-resources, exception handling syntax, diamond syntax), but
I'm not proposing this change in order to use a new "killer" feature.
What we need to decide is whether or not we will be constrained *not*
to use these features for the development cycle of Accumulo 1.6.x. If
the answer is no, don't switch, yes, be constrained, then we can
revisit the question at the beginning of the Accumulo 1.7.0
development cycle.

--
Christopher L Tubbs II
http://gravatar.com/ctubbsii
On Mon, Jun 3, 2013 at 5:49 PM, Adam Fuchs <[EMAIL PROTECTED]> wrote:
> Let's be specific: which Java-1.7-only feature is motivating this change?
> Without knowing the upside I am inclined to vote no because of the number
> of platforms that I regularly see that are running java 1.6.
>
> Adam
>
>
>
> On Mon, Jun 3, 2013 at 4:51 PM, Christopher <[EMAIL PROTECTED]> wrote:
>
>> Given all the previous discussions about this, and assuming all points
>> and counterpoints have already been sufficiently enumerated, I'd like
>> to put it to a vote, explicitly:
>>
>> Should we switch to JDK 1.7 for Accumulo 1.6.0, to take advantage of
>> newer features (ACCUMULO-905), or should we continue to require that
>> Accumulo 1.6.0 run on JRE 1.6?
>>
>> --
>> Christopher L Tubbs II
>> http://gravatar.com/ctubbsii
>>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB