Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # user >> NullPointerException when opening a region on new table creation


+
Viral Bajaria 2013-06-25, 10:23
+
Jean-Marc Spaggiari 2013-06-25, 11:22
+
Viral Bajaria 2013-06-26, 00:20
Copy link to this message
-
Re: NullPointerException when opening a region on new table creation
To close the loop here, I wasn't able to repro it again and it seems the
issue was due to a race condition in create table commands. Eventually the
tableinfo file was missing on HDFS and hence there was an exception storm.
I fixed it by manually creating the file with the right definition and then
eventually dropping the table.

-Viral

On Tue, Jun 25, 2013 at 5:20 PM, Viral Bajaria <[EMAIL PROTECTED]>wrote:

> Hi JM,
>
> Yeah you are right about when the exception happens. I just went through
> all the logs of table creation and don't see an exception. Though there
> was a "LONG" pause when doing the create table. I cannot find any kind of
> logs on the hbase side as to why the long pause happened around that time.
>
> The bigger problem now is the table does not show up in the hbase ui and I
> can't do a drop on it. At the same time the regionserver logs are flooded
> with that exception. I think I will have to muck around with ZK and
> remove traces of that table.
>
> Will try to repro this issue but it seems weird since I am able to create
> other tables with no issue.
>
> Thanks,
> Viral
>