Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Zookeeper >> mail # dev >> Fw: HBase accessing Tables


Copy link to this message
-
Re: Fw: HBase accessing Tables
Aditya,
 It seems like you are setting the hostnames as localhost in your
zoo.cfg. You will have to use real hostnames for that.

Hope that helps.

mahadev

On Wed, Dec 14, 2011 at 7:22 PM, Aditya Kumar <[EMAIL PROTECTED]> wrote:
> HI all,
>
>
> I am able to install the hadoop/Hbase and was able to create some tables.
>
> when I login to http://10.10.20.1:60010/master.jsp
> I am able to see all the tables I have created. b(from webpage)
>
> But when I try to see from HBASE shell noting is happening.
>
> ==> hbase(main):021:0* list
>
> TABLE
> 11/12/14 18:49:57 FATAL zookeeper.ZKConfig: The server in zoo.cfg cannot be set to localhost in a fully-distributed setup because it won't be reachable. See "Getting Started" for more information.
>
> ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: org.apache.hadoop.hbase.ZooKeeperConnectionException: org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /hbase
>
> Here is some help for this command:
> List all tables in hbase. Optional regular expression parameter could
> be used to filter the output. Examples:
> =>
> how can I see the list of tables?
> how to fix the Issue I am having?
>
> Can you please guide me.
>
> -Adi
>
>
>
> P.S: I initially posted to Hbase but later found that it is a zookeeper issue so posting in zoo keeper mailing list