Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop >> mail # user >> Hadoop in Eclipse


Copy link to this message
-
Re: Hadoop in Eclipse
If you want to test your mapper and reducers in eclipse, you can just link with hadoop libraries in project settings.

Regards,
Serge

From: Wilson Wayne - wwilso <[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>>
Reply-To: "[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>" <[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>>
Date: Mon, 7 May 2012 16:10:17 -0600
To: "[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>" <[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>>
Subject: Hadoop in Eclipse

I’m new to Hadoop and am trying to get it setup in Eclipse.  I’m following the “Working with Hadoop under Eclipse” wiki to do this.  First let me make sure this will do what I am hoping it will do.  I’m not so much interested in modifying the Hadoop code itself (although I may in the not too distant future).  I’m more looking to be able to code and test mappers and reducers in Eclipse and leverage the debugging and other tools in Eclipse in that process.  If that’s not what the wiki is describing than let me know that and ignore my issue.  If there is a way to do this, would you please point me to where I can find the instructions.  If this is what the wiki is describing than I have an issue I need help with.

I’ve followed the directions on the Wiki and even worked through a couple of issues by searching the archive.  However, now I’ve hit an error that while I did find it in the archive, the fix that was presented is not fixing my issue.  After importing all the projects, I get a build error: “Project ‘MapReduceTools’ is missing required library: ‘lib/hadoop-core.jar’”.  I’ve added the M2_REPO variable as someone suggested in the archive where I found this error once.  That hasn’t fixed or even changed the error.  I’ve looked in my maven repository (c:\Users\wwilso\.m2\repository) and there is not a “Hadoop-core.jar” anywhere in the repository that windows explorer can find.  In fact, windows explorer can’t find a “Hadoop-core.jar” anywhere on my c:\ drive.

I did my build using the directions from the wiki (got source using git in cygwin and then executing the two maven commands in cywgin).  I did use the patch for the “scripts/saveVersion.sh” not found error to resolve that issue.  That’s the only thing I have changed from the wiki or code.  Using Maven-3.0.4, ant-1.8.3, and protobuf-2.4.1.  Anyone have any ideas?  Thanks in advance.
WAYNE WILSON
Product Technical Consultant
Acxiom Corporation
EML   [EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>
TEL    501.342.2870
MBL   972.984.0268
5213 Rolling Rock Dr, McKinney, TX, 75070, USA
WWW.ACXIOM.COM<http://WWW.ACXIOM.COM>
[cid:[EMAIL PROTECTED]D440]<http://www.facebook.com/acxiomcorp>  [cid:[EMAIL PROTECTED]D440] <http://www.linkedin.com/groupRegistration?gid=2901735>   [cid:[EMAIL PROTECTED]D440] <http://twitter.com/acxiom>

[cid:[EMAIL PROTECTED]D440]
________________________________
The information contained in this communication is confidential, is intended only for the use of the recipient named above, and may be legally privileged. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please resend this communication to the sender and delete the original message or any copy of it from your computer system. Thank you.
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB