Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Hadoop, mail # user - Re: Datanode doesn't connect to Namenode


+
Jitendra Yadav 2013-08-07, 17:55
Copy link to this message
-
Re: Datanode doesn't connect to Namenode
Felipe Gutierrez 2013-08-08, 11:27
Thanks,
at all files I changed to master (cloud6) and I take off this property
<name>hadoop.tmp.dir</name>.

Felipe
On Wed, Aug 7, 2013 at 3:20 PM, Shekhar Sharma <[EMAIL PROTECTED]>wrote:

> Disable the firewall on data node and namenode machines..
> Regards,
> Som Shekhar Sharma
> +91-8197243810
>
>
> On Wed, Aug 7, 2013 at 11:33 PM, Jitendra Yadav <
> [EMAIL PROTECTED]> wrote:
>
>> Your hdfs name entry should be same on master and databnodes
>>
>> * <name>fs.default.name</name>*
>> *<value>hdfs://cloud6:54310</value>*
>>
>> Thanks
>> On Wed, Aug 7, 2013 at 11:05 PM, Felipe Gutierrez <
>> [EMAIL PROTECTED]> wrote:
>>
>>> on my slave the process is running:
>>> hduser@cloud15:/usr/local/hadoop$ jps
>>> 19025 DataNode
>>> 19092 Jps
>>>
>>>
>>> On Wed, Aug 7, 2013 at 2:26 PM, Jitendra Yadav <
>>> [EMAIL PROTECTED]> wrote:
>>>
>>>> Hi,
>>>>
>>>> Your logs showing that the process is creating IPC call not for
>>>> namenode, it is hitting datanode itself.
>>>>
>>>> Check you please check you datanode processes status?.
>>>>
>>>> Regards
>>>> Jitendra
>>>>
>>>> On Wed, Aug 7, 2013 at 10:29 PM, Felipe Gutierrez <
>>>> [EMAIL PROTECTED]> wrote:
>>>>
>>>>> Hi everyone,
>>>>>
>>>>> My slave machine (cloud15) the datanode shows this log. It doesn't
>>>>> connect to the master (cloud6).
>>>>>
>>>>>  2013-08-07 13:44:03,110 INFO org.apache.hadoop.ipc.Client: Retrying
>>>>> connect to server: cloud15/192.168.188.15:54310. Already tried 9
>>>>> time(s); retry policy is RetryUpToMaximumCountWithFixedSleep(maxRetries=10,
>>>>> sleepTime=1 SECONDS)
>>>>> 2013-08-07 13:44:03,110 INFO org.apache.hadoop.ipc.RPC: Server at
>>>>> cloud15/192.168.188.15:54310 not available yet, Zzzzz...
>>>>>
>>>>> But when I type jps command on slave machine DataNode is running. This
>>>>> is my file core-site.xml in slave machine (cloud15):
>>>>>  <configuration>
>>>>> <property>
>>>>>   <name>hadoop.tmp.dir</name>
>>>>>   <value>/app/hadoop/tmp</value>
>>>>>   <description>A base for other temporary directories.</description>
>>>>> </property>
>>>>>
>>>>> <property>
>>>>>   <name>fs.default.name</name>
>>>>>   <value>hdfs://cloud15:54310</value>
>>>>>   <description>The name of the default file system.  A URI whose
>>>>>   scheme and authority determine the FileSystem implementation.  The
>>>>>   uri's scheme determines the config property (fs.SCHEME.impl) naming
>>>>>   the FileSystem implementation class.  The uri's authority is used to
>>>>>   determine the host, port, etc. for a filesystem.</description>
>>>>> </property>
>>>>> </configuration>
>>>>>
>>>>> In the master machine I just swap cloud15 to cloud6.
>>>>> In the file /etc/host I have (192.168.188.15  cloud15) and
>>>>> (192.168.188.6   cloud6) lines, and both machines access through ssh with
>>>>> out password.
>>>>>
>>>>> Am I missing anything?
>>>>>
>>>>> Thanks in advance!
>>>>> Felipe
>>>>>
>>>>>
>>>>> --
>>>>> *--
>>>>> -- Felipe Oliveira Gutierrez
>>>>> -- [EMAIL PROTECTED]
>>>>> -- https://sites.google.com/site/lipe82/Home/diaadia*
>>>>>
>>>>
>>>>
>>>
>>>
>>> --
>>> *--
>>> -- Felipe Oliveira Gutierrez
>>> -- [EMAIL PROTECTED]
>>> -- https://sites.google.com/site/lipe82/Home/diaadia*
>>>
>>
>>
>
--
*--
-- Felipe Oliveira Gutierrez
-- [EMAIL PROTECTED]
-- https://sites.google.com/site/lipe82/Home/diaadia*