Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # user >> No info for Accumulo Master on Monitor Overview page


Copy link to this message
-
Re: No info for Accumulo Master on Monitor Overview page
In our installation the hdfs account has hdfs as his primary group and
hadoop as a secondary group.  Our accumulo account has accumulo as his
primary group.

I added both hdfs and hadoop as secondary groups for the accumulo account,
but no joy -- still a blank Accumulo Master summary box on the overview
page.

So do both the accumulo and hdfs users have to have the same *primary *group
then?

I put accumulo into a separate group in order to protect the shared secret
in accumulo-site.xml, but I guess the better approach is to have both
accumulo and hdfs in the same Linux group and just protect this file by
making it readable by owner only?  If both accumulo and hdfs users must
have the same primary group, looks like that's about the only option.

On Thu, Jun 6, 2013 at 4:57 PM, Eric Newton <[EMAIL PROTECTED]> wrote:

> Yea, that's a 1.4.2 issue.  You can work around it by putting the accumulo
> and hdfs accounts into the same group, or just ignore the display issue.
>
> ACCUMULO-1282
>
> -Eric
>
>
>
> On Thu, Jun 6, 2013 at 5:48 PM, Terry P. <[EMAIL PROTECTED]> wrote:
>
>> Hi Eric,
>> Sorry I should have thought of including a screenshot.  I've attached one
>> to this email -- first one I've done, I hope it works just like a regular
>> attachment?
>>
>> To ensure I had a clean monitor log, I shutdown Accumulo and started it
>> up again.  First there are all the [server.Accumulo] entries, here's the
>> head of that which looks good:
>>
>> 2013-06-06 21:34:37,823 [server.Accumulo] INFO :  monitor starting
>> 2013-06-06 21:34:37,824 [server.Accumulo] INFO :  Instance
>> 22e13d96-d1ac-45c7-9d90-ae2e813e983c
>> 2013-06-06 21:34:37,841 [server.Accumulo] INFO :  Data Version 4
>> 2013-06-06 21:34:37,841 [server.Accumulo] INFO :  Attempting to talk to
>> zookeeper
>> 2013-06-06 21:34:38,026 [server.Accumulo] INFO :  Zookeeper connected and
>> initialized, attemping to talk to HDFS
>> 2013-06-06 21:34:38,030 [server.Accumulo] INFO :  Connected to HDFS
>> 2013-06-06 21:34:38,034 [server.Accumulo] INFO :  gc.cycle.delay = 5m
>> 2013-06-06 21:34:38,034 [server.Accumulo] INFO :  gc.cycle.start = 30s
>> 2013-06-06 21:34:38,034 [server.Accumulo] INFO :  gc.port.client = 50091
>> 2013-06-06 21:34:38,034 [server.Accumulo] INFO :  gc.threads.delete = 16
>> 2013-06-06 21:34:38,034 [server.Accumulo] INFO :  general.classpaths >>     $ACCUMULO_HOME/src/server/target/classes/,
>>     $ACCUMULO_HOME/src/core/target/classes/,
>>     $ACCUMULO_HOME/src/start/target/classes/,
>>     $ACCUMULO_HOME/src/examples/target/classes/,
>>         $ACCUMULO_HOME/lib/[^.].$ACCUMULO_VERSION.jar,
>>         $ACCUMULO_HOME/lib/[^.].*.jar,
>>         $ZOOKEEPER_HOME/zookeeper[^.].*.jar,
>>         $HADOOP_HOME/conf,
>>         $HADOOP_HOME/[^.].*.jar,
>>         $HADOOP_HOME/lib/[^.].*.jar,
>>
>> Then at the very end I found (with only INFO messages in between):
>>
>> 2013-06-06 21:34:39,132 [monitor.Monitor] WARN :
>> java.lang.NullPointerException
>>         at
>> org.apache.accumulo.server.monitor.Monitor.fetchData(Monitor.java:308)
>>         at
>> org.apache.accumulo.server.monitor.Monitor$2.run(Monitor.java:476)
>>         at
>> org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
>>         at java.lang.Thread.run(Unknown Source)
>>
>> That's the last entry in the monitor log.
>>
>> The second image I attached shows the Master Status page, showing there
>> is no problem with that display.
>>
>> This is Accumulo 1.4.2 running as linux account 'accumulo' -- HDFS runs
>> as the hdfs account, which is why the NameNode section shows "permission
>> denied."  NameNode and Accumulo Master reside on the same server.  OS is
>> Red Hat Enterprise Linux 6.3 64-bit.
>>
>> Thanks in advance,
>> Terry
>>
>>
>>
>> On Thu, Jun 6, 2013 at 2:58 PM, Eric Newton <[EMAIL PROTECTED]>wrote:
>>
>>> Would you have a screenshot?  Any messages in the monitor log?
>>>
>>> -Eric
>>>
>>>
>>>
>>> On Thu, Jun 6, 2013 at 2:44 PM, Terry P. <[EMAIL PROTECTED]> wrote: